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Pieces Of Eight, or Is It 16?
One of the most exciting new features of 
Pattern Editor is one that might not be 
readily apparent at first.

 A pattern can be thought of as a matrix of 
points. The height of each point used to be 
described by a number from 1-255 (8 bits 
in computer jargon). While this worked 
fine the majority of the time when a 
pattern was carved full depth (0.8”) it 
could lead to a slightly visible stepped 
effect. To prevent the stepped effect, both 
Pattern Editor and Designer now make use 
of 16-bit patterns. When you load in an 
older pattern it will be automatically 
upgraded to the new 16-bit format. The use 
of a 16-bit pattern format makes for 
smooth patterns. There are a few other 
changes related to the shift to 16-bit 
patterns.

In order to improve ease of use, several of 
the controls in PE now displays in inches 
instead of pixel weights. This makes it 
much easier to specify exactly the height 
you want. These modified controls 
include: Tool Height, Raise/Lower filter, 
and the selection Tolerance. You can 
change the value in these controls in the 
same old way by clicking on the Up/Down 
arrows or by typing in a new value. (fig.1)
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Please visit the 
manufacturer’s website 

for more information 
about the CarveWright 
machines and see the 
new Pattern Depot at:

For Additional Patterns
you can add to your 
Designer software 
library, please visit:

www.carvewright.com

www.carvebuddy.com

Pattern Editor - Episode III

Editor Preface: Please join me 
in welcoming Jeff Birt as the 
author for this month’s Tips 
newsletter! It has been more 

than a year since the Tips 
& Tricks covered the 

Pattern Editor and in that 
period of time several things have 

changed and new tools have been added. 
This month, Jeff will cover changes to the 
Pattern Editor since the July and August 
2008 editions of Tips & Tricks were 
published. Now...here’s Jeff!

Pattern Editor Episode III
Just in case you're not familiar with 
CarveWright’s Pattern Editor let's take a 
few minutes to talk about what it is and 
what it can help you do. 

The Pattern Editor, also called PE, is an 
additional software package used to create 
and edit patterns for use by CarveWright’s 
Designer. A PE license is included when 
you purchase the CarveWright Scanning 
Probe and it can also be purchased 
separately. (visit www.carvewright.com for 
more information on purchasing the probe 
or Pattern Editor.) The Pattern Editor 
works with three main types of files which 
can be identified by their three letter file 
type extension: MPW, PTN, and image 
formats such as GIF, BMP, PNG. As you 
may already know, the PTN (pattern) file 
type denotes a type of 3 dimensional 
clipart that is unique to the CarveWright 
system, the MPW file is an artwork file 
used to store patterns being edited.

by Jeff Birt of Soigeneris.com - Michael Tyler, Editor
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Launching The Pattern Editor
Before you can edit a file with Pattern Editor you have 
to be able to launch the program itself. In the past you 
had to start up Designer and then ‘Open’ a file type that 
was native to the Pattern Editor (MPW or PTN). Now 
to make things easier from within Designer you can 
simply select ‘File->Launch Pattern Editor’.  In 
addition you can also launch Pattern Editor by double 
clicking on a pattern you have authored in your 
Favorites Library. (fig. 2)

Opening A FileTo Edit
 The Pattern Editor is designed to edit two different 
CarveWright System native file types: MPW and PTN. 

An MPW file is a raw file format, its job is to it hold all 
the unique pieces that might make up a pattern.  The 
MPW file can only be opened in Pattern Editor and it 
can be freely edited by other uses. 

A PTN file on the other hand should be thought of as a 
finished work; it can be used by others in Designer but 
can only be edited by the original creator in PE. While 
the user may not see a difference when loading a PTN 
vs. a MPW file, under the surface there is a difference. 

 A good rule of thumb is to save your works in progress 
as MPW’s and when you are finished editing save the 
finished work as a PTN file for use in Designer.
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Since the MPW and PTN files are the native file types 
of the CarveWright system you simply use the ‘Open’ 
selection from the ‘File’ menu to load in the file of 
your choice. 

Remember that if you are not the original creator of a 
PTN file you will not be able to edit it, whereas a 
MPW is freely editable by others. Pattern Editor also 
has the ability to import common image file types such 
as PNG, GIF, BMP and JPG.

This brings us to one of the recent changes in the 
Pattern Editor’s File menu. In an effort to more closely 
follow the convention of other graphical editing 
software these non-native image file types are 
'Imported' into Pattern Editor. 

Using the ‘File->Import’ selection you can import an 
image into PE where it is converted internally into an 
MPW file. (fig.3) Thus when you are editing an 
imported image you are editing the MPW that was 
created from that image.  

In a similar manner you can export the current file 
being edited as an image file by using the ‘File->Export’ 
selection.
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You Can Never Have Too Many Tools
If you have taken a recent look at the Filter Menu you 
may have noticed that there is a new ‘Trim Edges’ 
filter. ‘Trim Edges’ works by walking around the 
edges, both interior and exterior, of a pattern and 
removing the number of pixels selected by the user.  
This makes cleaning up the jagged edges of a scan or 
other artwork a very easy. (fig. 4a, 4b)
 

(cont.)

As you can see, applying the ‘Trim Edges’ filter 
removed the extra halo from the shell pattern. It’s a 
good idea to follow up the ‘Trim Edges’ filter by 
applying the ‘Round Edges’ filter. This will ensure a 
smooth transition from the pattern’s edge to the 
pattern’s floor.

Extra Room To Work
In the past, some users ran into a problem trying to edit 
the edges of a pattern. If the pattern had been cropped 
in tight there were no ‘free pixels’ left at the pattern’s 
edge. This made it impossible to fill in missing 
sections and applying filters like Smooth and Blur 
could cause a more pronounced edge as there was no 
place left for them to work. To overcome this problem 
PE now automatically adds a blank canvas behind the 
pattern as it is loaded. In addition, this canvas is 
automatically sized to provide a border around the 
pattern giving you (and any filters) room to work.

To get an idea of how large the canvas is you can use 
the new ‘Highlight Edit Area’ tool which is available in 
the ‘View’ menu. (fig. 5a)

This tool highlights the blank editable canvas in a 
transluscent red color. This will show you how much 
room you have to work in. When you save your 
artwork, PE will automatically crop to just the visible 
area of the pattern itself this helps to prevent the large 
box that used to surround some patterns when placed 
on the board in Designer. (fig. 5b - next page)
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Extra Room To Work (cont.) 
With this new larger canvas to work in, how do know what the size of your pattern really is? Pattern Editor keeps 
track of the visible extents of your pattern and this ‘effective size’ is the size displayed in the Width and Height 
boxes. All of the extra working room provided by the canvas is not included. If you reduce or enlarge the pattern 
only this visible area is scaled. This way you are ensured that your pattern will be accurate and ‘Life Sized’ when 
used in Designer.

(cont.)
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fig. 5b

Notice that the Width and Height size boxes display the actual 
pattern size itself - also referred to as the pattern’s “visible extents”. 

The size of the background canvas has no effect on the actual size 
of the pattern. The background canvas (in translucent red color) 
simply provides additional workspace around the perimeter of the 
pattern.
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Selection Perfection
There have been improvements to the selection tools as 
well.  The selection tools such as the ‘Magic Wand’ 
and the ‘Rectangular Selection’ area allow you to 
choose only certain areas of the pattern to be modified.

The Magic Wand, which is used to select all pixels 
within a height range (Tolerance) of the selected pixel, 
now has a few new friends; the ‘Magic Wand-Upper’ 
and ‘Magic Wand-Lower’ tools make it easy to select 
all pixels above or below the pixel you select. (fig. 6a)

In the picture below, I used the ‘Magic Wand – Upper’ 
tool to select all the pixels above where I clicked. It 
was then very easy to use the eraser tool set to 0.1” to 
flatten the top of the pattern. (fig. 6b)

To make it easier to select only what you are after there 
is also a new selection related option. The ‘Foreground 
Only’ check box tells PE to ignore any parts of a 
selection area that are blank, that way 
you can avoid filling in blank areas 
while editing a region.

Ride the Magic Paint Brush
When filling in small missing in sections of a scan it 
could be a bit frustrating to try and manipulate the 
paint tool into just the right area. If you’re not careful 
you can accidently lower the surrounding region.  To 
make jobs like this easier the Magic Paint Brush was 
developed. The Magic Paint Brush works just like the 
regular paint brush except it can only paint higher 
levels; it cannot lower existing areas of a pattern. It’s 
perfect for filling in holes and ‘dents’. In the images 
below, I have a small divot to fill in (fig. 7a). When I 
used the ‘Paint Brush’ tool, I accidently made things 
worse because I painted the surrounding area lower 
than it already was (fig. 7b). Using the ‘Magic Paint 
Brush’ I was able to work from the lower part of the 
divot upwards doing just a few fills and having very 
little effect on the surrounding area (fig.7c). To finish 
the repair up I used the ‘Blur’ to smooth things out
(fig. 7d).

(cont.)
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fig. 7d
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Eraser Tool
The ‘Eraser’ tool is certainly not new but it does seem 
to cause some confusion at times. The ‘Eraser’ not 
only allows you to completely erase an area it also 
allows you to set the level that it erases down to.  For 
instance if the tool height is set to 0.000” it will 
completely erase an area, but if you set the tool height 
to 0.100” you can erase an area down to the level of 
0.100”.

You might be thinking that being able to erase down to 
a level sounds an awful lot like the ‘Paint Brush’ or 
‘Magic Paint Brush’ tools but there is an important 
difference. Remember that the ‘Paint Brush’ will paint 
over anything; it changes anything underneath the 
brush to the level of the brush. The ‘Magic Paint 
Brush’ can raise the level of the pattern underneath it 
but not lower it. The ‘Eraser’ can lower the level of the 
pattern underneath the brush but not raise it. This gives 
you, the user, complete control over how you alter the 
pattern. (fig. 8)

The Carving Tools
While all the painting type tools are great, they all 
have a common drawback; they all draw flat and level. 
If you want to modify a contoured area it can be quite 
difficult. 

To make touching up contours easier the Carving Tool 
was developed. The Carving Tool follows the contour 
of the underlying pattern and carves in a selectable 
profile. The 'Tool Pressure' control can also be used to 
control the depth of the carve.

The Carving Tool (fig. 9a) was designed to mimic the 
process of carving a piece of wood with carving 
knives. You can select the profile of the virtual carving 
knife and the pressure used to apply it (fig. 9b). The 
more pressure you apply the deeper you will carve. 
You can also control the size of the knife using the 
same ‘Size’ control that you use for the brush type 
tools (fig. 9c).

 

(cont.)
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Rectangle can be 
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using this size board
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Help!
One item that has been conspicuously missing from 
Pattern Editor, namely the Help File, has now been 
added to the ‘Help’ menu. 

At this time only a basic description of each tool is 
given, but it is nice for a quick reference and the help 
file will be updated over the course of time. 

This Tips & Tricks issue should help fill in a few more 
details for you in the meantime.

 

(cont.)
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I hope you have found this article helpful! Please sign 
up on the  to have the monthly 
newsletters automatically delivered to your email 
address each month. You’ll see a “Join Our Mailing 
List” section. Just fill in the form and you’ll be all set!

CarveWright Homepage

Michael Tyler - Editor

Special thanks to 
Jeff Birt of

for providing
the content for this issue of

CarveWright TiPS and TRiCKS.

soigeneris.com

CONCLUSION 
Thank you, Jeff for writing up this Pattern Editor 
tutorial for us! Be sure to show your appreciation for 
Jeff’s contribution by visiting his website at:

Jeff’s website has numerous items that you may find 
interesting, including a Backlit LCD Kit for the 
CarveWright and Compucarve! 

http://soigeneris.com

http://www.carvewright.com/store/product.php?productid=18302&cat=263&page=1
http://soigeneris.com
http://soigeneris.com


RESOURCES...
There are numerous resources for the CarveWright/CompuCarve owner to make their experience with these 
machines much more enjoyable. 

Every owner should join the  where fellow users share their experiences and knowledge 
with these machines on a daily basis. It is a FREE service that you will surely appreciate. A handy Search Feature 
helps you find answers to any questions you may have.

CarveWright User Forum

Additional Resources

The trademarks, service marks and logos (the “Trademarks”) used and displayed here are registered and unregistered Trademarks of LHR and others.

CarveWright TiPS & TRiCKS - OCTOBER 2009
www.carvewright.comPage 8

http://www.carvewright.com/forum/index.php
http://www.carvewright.com/store/product.php?productid=18302&cat=263&page=1
http://carvewright.com/store/home.php?cat=261
http://carvewright.com/store/home.php?cat=258
http://carvewright.com/store/pattern.php?vendor=carvebuddy
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