
In case some of you may not be 
familiar with the Pattern Editor 
software - it’s the software that 
is primarily used to convert  

“raw” probe scans (called 
mpw artwork files) into 

patterns (called ptn files) that 
you ultimately import into your 

Designer Pattern Library. Additionally, 
the software allows you to open graphic 
files, perform minor editing in a split-
screen Standard View and  “3D 

heightmap View”, then re-save them as 
artwork files (mpw), pattern files (ptn), or 
even as “png” graphic files.

The Pattern Editor software is included 
when you purchase the CarveWright 3D 
Scanning Probe. The software is also 
available apart from the scanning probe as 
a separate purchase. However, you may 
want to just go ahead and purchase the 
Scanning Probe since you’ll automatically 
receive the Pattern Editor software and 
activation as part of the package. Besides, 
as a Scanning Probe owner, you’ll be able 
to easily create an unlimited supply of 
scanned dimensional relief patterns to add 
to your collection! It’s a great value.

The Pattern Editor software is continually 
maturing as its existing features are 
improved and new feature additions are 
considered and tested. At the time of this 
writing, there is not a Help File available 
within the software yet. In the meantime, 
this issue will cover the main features and 
functions of the Pattern Editor.

July 2008

For More Information About  the 
Scanning Probe

Please visit:

For Information About Purchasing the
Pattern Editor Separately

Please Visit:

(then click on “Software”)

Starting/Opening the Pattern Editor
The Pattern Editor will open when you 
double-click (or use right-click->Open) on 
any pattern file (ptn) you created yourself, 
or of course, when you download a scan 
from your memory card to your computer 
via the File Menu in the Designer software 
(File->Download Scan). 

You can also start/open the Editor when 
you click File->Open in Designer and 
select a file type that the Editor uses (mpw, 
ptn). The Pattern Editor is actually an 
integrated part of your Designer software, 
so if the pattern Editor is open, so too will 
be your Designer software. Conversely, 
the Designer software can be opened and 
used without the Pattern Editor being 
open. (Perhaps I have stated the obvious 
here, since I’m sure you realize that not 
everyone will own or use the Pattern 
Editor software.)

NOTE: For much of this article, I’ll often 
abbreviate the term “Pattern Editor” as 
simply “PE”.

http://www.carvewright.com/cms/probe

http://www.carvewright.com/store/
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Please visit the 
manufacturer’s website 
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about the CarveWright 
machines and see the 
new Pattern Depot at:

For Additional Patterns
you can add to your 
Designer software 
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The Main Menus
I’m sure you already know how to navigate the basic File and Edit Menu tasks such as New, Open, Save, Save As, 
Undo, Redo, etc. That functionality is common to nearly all software programs so I won’t waste too much of your 
time on particularly obvious and familiar operations so I’ll mainly comment on PE’s more specific tools and 
unique functions (fig. 1 - 16). One reference to a “basic item” I need to mention specifically regarding the PE 
software is that the Paste function is currently non-operational at the time of this writing and will have no effect 
within PE if you try to use it. NOTE: Be aware that you  copy (or cut) a selection in PE (the copy/cut copy is 
held in the Clipboard) and you can paste the copy into a different graphic application if you desire.

can
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fig. 1

The PE File Menu

fig. 2

The PE Edit Menu

Transfers a scan from
your memory card to the PE.

Allows you to save your file to
the png graphic format

Saves your file as a Pattern (ptn)
file in your Designer Library

You can open your own patterns (ptn), a raw scan (mpw)
or open any of the following graphic file types:
bmp, jpg, jpeg, png, mng, gif, xpm
(Note: an mpw file is also referred to as “Artwork” but I’ll
use the term “artwork” for any open file being edited)

This column lists the keyboard shortcuts
you can use instead of opening the menu
and clicking these options with your mouse.

Allows you to Flip or Rotate the 
pattern, graphic or artwork you are editing

Allows you to assign a name and write a description  
for the pattern, graphic or artwork you are editing

Used after you make a selection, this will
remove anything outside of the selection.

NOTE: Always crop your artwork after 
editing, before saving it to a pattern.

List of the keyboard shortcuts
for the Edit Menu

Paste is non-functional
within the PE at this time

Used after you make a selection, this willl
remove anything inside of the selection

(it also copies the selection to the 
Clipboard for pasting into another 

graphic application if you so desire)

Copies a selection to
the Clipboard



The Main Menus (cont.)
The Filter Menu (fig. 3) contains several features for adding final touches to your overall artwork before saving 
the result as a pattern. Filters will affect either the entire artwork or you can select an area and apply the filter 
exclusively to only selected areas. These filters are duplicates of the docker bar icons you see in the main interface 
window but this menu lists the keyboard shortcuts, as well.

The CarveWright Pattern Editor

fig. 3 The PE Filter Menu
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Inverts the shades of the artwork, which reverses the heightmap depths.

This brings the outside edges of a scan or graphic down 
to the zero plane (improves rough, irregular, or 
incomplete edges). It doesn’t actually “round over” the 
edges as the name might imply. 

Raise/Lower functions as a type of brightness/contrast 
adjustment. As the image becomes darker, the 
heightmap becomes lower overall. As the image is 
adjusted brighter, the heightmap becomes taller overall.

The Smooth filter tones down differences in adjacent 
pixels, resulting in only a slight loss of detail while 
smoothing the overall image or selected area. What it 
does is smooth the smallest details while attempting to 
maintain the sharpness of larger edges—effectively 
cleaning up the image. Don’t overuse - a value of 2 or 3 
is usually enough.

The Blur filter softens an image overall, including 
details. Blur works by averaging the shade of pixels 
next to the hard edges of defined lines and shaded 
areas in an image and has the effect of "blending" 
details so that they are less obvious. Overuse of blur 
will remove too much detail resulting in kind of an 
undesireable "melted chocolate effect". Stay at a low 
value of 2 or 3 if possible.

De-noise filtering has very little effect on scanned items 
(mpw files) you are editing. However, it can certainly 
help clean up imported graphics (such as jpeg files). 
Artifacts (noise) that are present in some graphics can 
be significantly reduced by using the De-Noise Filter.

The Quantize filter reduces the number of shades in 
your artwork. This can be extremely useful for cleaning 
up and defining raised areas in simple 3 or 4-color logo 
graphics that you wish to create a neat pattern from.



The Main Menus (cont.)
The Tools Menu has some of the same icons you’ll see on the main PE interface. You’ll notice that each of the 
tools listed have convenient keyboard shortcuts that you can use instead of clicking on the menu or an icon. (fig. 4)
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The CarveWright Pattern Editor

fig. 4 The PE Tools Menu

The standard selection arrow

This is used to “paint” your pixels when editing.
The brush can be resized via the Brush docking tool bar.

This is used to erase undesired areas. The 
erase tool also functions as an “Undo” tool. 
Hold down the Ctrl key on your computer 
keyboard and move the eraser over any area 
you have previously edited while holding down 
the left mouse button. It will undo all edits that 
the eraser passes over, restoring those areas 
to their original state.

The Blur Tool “brush” softens artwork by 
averaging the shade of adjacent pixels. Hold 
the left mouse button down while moving the 
“brush” over areas you want blurred.

Fills a selection with the color or shade you 
have chosen. Aim with the “paint pour” end.

The Dropper is used to select a shade or color 
value by left-clicking the mouse when over the 
desired shade. The shade is displayed as a 
numerical height value in the main interface 
Height box display. Numbers range from 0 
(lowest height) to 255 (tallest height).

Allows you to rotate your artwork in the edit 
window by click/dragging a directional 
guideline to rotate the art into any position you 
desire. Useful for straightening skewed 
artwork/scans before saving as patterns.

Hold the left mouse button down and drag to 
draw a rectangle-shaped selection.

When clicked over your artwork, the Magic 
Wand will select an area of similarly shaded 
connected (contiguous), or non-connected 
pixels. Sensitivity tolerance is adjustable via 
the Input toolbar.



The Main Menus (cont.)
The View Menu (fig. 5) has various tools for viewing your artwork in the left viewing pane of the PE interface. 
One new tool which applies only to the right-side viewing pane (the editing side) is the 2D Colorization option. 
This became available starting with the release of the 1.30 version of the software. It allows you to toggle between 
a conventional greyscale heightmap view and a colorized heightmap view of your artwork.
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The CarveWright Pattern Editor

Click on the far right arrow to turn on or off 
visibility of various docking toolbars.

fig. 5 The PE View Menu

Clicking the far right arrow gives you 8 options 
for lighting direction in relation to the artwork.

Clicking this icon toggles between a 
perspective view and a “straight-on” view.

Clicking this icon toggles on/off the display of 
the board texture/grain. Recommended: Turn 
the texture “off” when editing. {
These allow you to move the artwork left/right, 
up/down (pan), rotate in 3D space, and zoom in and 
out (magnify). NOTE: The keyboard shortcuts for each 
are in parenthesis. It is not really necessary to ever 
click these icons - it is faster and easier to just use the 
keyboard shortcuts along with your mouse.

Restores the view to the default Front View.

Tilts the artwork to view it at a preset angle for 
a quick visual rendition of height, width, and 
depth relationship of your artwork object.

Click this icon to display an options menu for 
colorization or no colorization of the right-side 
pane heightmap view. (fig. 6) 

fig. 6 The Colorization Menu

A checkmark in this box turns off the colorization. 
Click inside the box again to remove the checkmark and turn 
on colorization. Left-click and hold your mouse button and 
move the cursor over the dial to adjust the colorization.
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The Main Menus (cont.)
The Help Menu (fig. 7) has a non-functional “Help Contents” link at the time of this writing. It does have an 
“About” menu item which will display the version of the Pattern Editor you currently have installed on your 
system.

The CarveWright Pattern Editor

fig. 7 The PE Help Menu

Non-functioning at the time of this writing.

Click to display the version of your PE.installed 

The Docker Toolbars (View->Toolbars)
There are 8 Docker Toolbars - 7 are listed here. Clicking on the 
checkmarks or name toggles the toolbars on and off.  
Normally, you will keep them all “on”.
The toolbar not listed is the “Adjust Size Toolbar”. {

If you have moved the toolbars, this lines them up again automatically.

Allows you to add/remove items that appear on each toolbar. (fig. 8)

fig. 8 CustomizeToolbar Menu

Click this option for Large icons to be displayed.

Click this option to display all icons’ 
names. Very handy when first starting to 
learn the program. NOTE: Alternatively, 
you can simply “hover” your mouse 
cursor over any toolbar icon and a “tool 
tip” icon label will appear within a 
couple seconds, without using the “Show 
Icon Labels” option.

The Docker Toolbars



The Docker Toolbars (cont.)
Here are all the toolbars with their functions labeled and described. (fig. 9)

The CarveWright Pattern Editor
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fig. 9
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Type in or use arrows
to set a Brush Size (in pixels)

Preset Brush Sizes A,B,C

Preset Brush
Shapes & edge
types 
(hard or soft)

Custom Brush Types
(non-functional at time of this writing)

Shows current
Brush selection

Opens Standard/Custom
Brush Menu

Zoom in (left-click while in View or Edit panes)
Zoom out (ctrl-left-click in View pane, right-click in Edit pane)*
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The Docker Toolbars (cont.)

The CarveWright Pattern Editor

fig. 12
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fig. 14
These functions are self-explanatory.
NOTE: After applying any of these functions,
the pattern will be saved in the orientation
you selected from this toolbar.
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The Docker Toolbars (cont.)

The CarveWright Pattern Editor

fig. 15
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Special notes about the Adjust Size Toolbar: You can type in your own values for the width, 
height and depth of your artwork (very similar to the functions in the Designer interface). Keep 
the Padlock icon turned “on” so that the width/height proportions will stay in sync with each 
other. Depth is set separately. Generally, when you “upsize” an object, the detail will be better 
if you “upsize” (increase) the depth as well. Experiment as you wish, until you achieve a 
practical best result.

Special notes about the “Height” & “Tool Strength” features in the Input Toolbar: 
You can achieve a sort of “sculpting tool” capability by experimenting with the strength and 
depth settings of either the Paint or Eraser Tools. Example: Open any ptn, mpw, or graphic 
file in PE. Select the Paint Tool, select a soft-edge brush and set its shade/height to “0”. Now 
set a low strength value (try a setting of “2”). Paint over your artwork and you’ll see the effect 
of the paint brush “carving” into it, instead of creating abrupt edges if strength was set at 100. 

With the Paint tool still selected, change the shade/height to 255. Now when you paint, it will 
“add material” to any areas with a shade/height less than 255. Use the Blur Tool to blend the 
edges of your “sculpted” areas further. With some practice, this feature can be useful for 
adding, enhancing or carving details in your artwork! Try experimenting with the settings when 
using the Eraser Tool. You can make a “weak” or a “strong” Eraser!
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The CarveWright Pattern Editor
Tutorial on the use of the Colorization Feature in PE version 1.30 and up - written by Jeff Birt

One of the exciting new features in CarveWright's new Pattern Editor 1.130 is Colorization. The first question that 
will come to mind when you see it is, “Why colorize the 2D pattern view?” What's wrong with plain old grayscale? 
Let's take a look at Colorization and see how it helps our pattern editing endeavors.

As you know CW patterns are essentially grayscale images where the level of gray determines the depth of carving. 
Our eyes can only distinguish about 50 shades of gray in an image. In contrast, we can see several million distinct 
colors. So, it only makes sense that we will be able to visually distinguish much more detail, in the 2D view of a 
pattern, if we could view it in color rather than grayscale. Colorization displays the 2D view of a pattern in pseudo-
color without changing the patterns actual grayscale. So, what about the color pallet chosen? About 8% of men and 
2% of women are colorblind with red/green colorblindness being the most prevalent. The colorization pallet was 
chosen to reduce any problems for those carvers who may have some level of colorblindness.

Figure 17 shows a standard view of a colorized 2D pattern image. The Colorization, shown in the lower right hand 
corner, can be displayed by clicking 'View->Colorization'. This dialog is non-modal, which means that you can 
keep it displayed while using Pattern Editor. I prefer to drag it over to the side, out of the way. The dial and 
accompanying spin-box (number box with Up/Down arrows) can be used to shift the colorization pallet. This can 
be helpful to further distinguish features that are very close in height. The pattern display automatically updates as 
you adjust the dial so you can immediately see the change. Clicking 'OK' will close the dialog and keeps the current 
settings.

fig. 17

Notice that we can tell the 
left side is slightly lower 
than the right.
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Tutorial on the use of the Colorization Feature in PE version 1.30 and up - written by Jeff Birt (cont.)

Pressing 'Cancel' discards any changes made since the dialog was displayed and closes the dialog. Pressing 'Reset' 
returns the dial to its default setting. You can also check the 'No Colorization' box to turn off colorization. The non-
shifted pallet ranges from a lime green at the lowest level to a blue/white at the highest level.

The pattern shown is from a scan of an antique casting. This particular casting required much physical restoration 
(filling, sculpting, sanding), before scanning. We can see right away that both sides of the tapestry are relatively 
level. However, we can also see that the bottom ribbon is a bit lower on the left-hand side. In this particular case it 
was a great help to see that the restoration work was kept even from side to side. Compare this to Figure 18; you'll 
notice that these details are hidden from us in the grayscale view.

The CarveWright Pattern Editor (cont.)The CarveWright Pattern Editor

fig. 18

Comparing figures 17, 18 and 19: This is the same unaltered. Notice that the background in Figures 17 & 18 
looks flat and level; however, if we shift the color pallet just a bit (5), we reveal a slight taper to the background. 
Now that we can easily see the taper we can use other Pattern Editor tools to fix it. For instance we can use the eye 
dropper to find the levels of the two different background shades; which were '1' and '9' in this case. Knowing this 
range we can use the fill tool set to our desired level, say '1', then we can set the tolerance to '8' (9-1=8), with these 
settings we’ll be able to fill the whole background area in one step. 



The CarveWright Pattern Editor (cont.)The CarveWright Pattern Editor
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As you can see Colorization is a nice addition to Pattern Editor. It allows us to easily visualize the heights of the 
various parts of a patterns’ 2D view in much more detail than is possible in grayscale alone. With this enhanced 
visualization we can more easily check and adjust the heights of various portions of our patterns and ensure that 
areas that should be level are level. The shift-able colorization pallet allows further control by allowing us to 
differentiate pattern features with only slight differences in height.  I'm sure with a little experimentation you can 
think of even more uses for Colorization. —end —

Tutorial on the use of the Colorization Feature in PE version 1.30 and up - written by Jeff Birt (cont.)

fig. 19

Conclusion

I hope that this Tips & Tricks issue has helped you 
learn more about the Pattern Editor’s useful features. 
Next month I’ll have a couple more tutorials on 
specific PE functions with illustrated examples similar 
to the wonderful contribution from Jeff Birt this month!

Until then...Happy Carving!

Special thanks to Jeff Birt of
 

&
Michael Tyler of

for providing
the content for this issue of

CarveWright TiPS and TRiCKS.
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